Две могучие функции EXCEL: СУММЕСЛИ и СЧЕТЕСЛИ

Нам нужно суммировать ячейки, выбранные по определенному условию. Или подсчитать количество ячеек, удовлетворяющих условию. Вот самый эффективный способ: используем функции СУММЕСЛИ и СЧЕТЕСЛИ.

Например, у нас есть следующая таблица:

СУММАЕСЛИ

Пусть это будут рейсы в определенные города и какие-то экономические результаты этих поездок.

Как подсчитать приход и расход по Москве и количество рейсов в Москву (т.е. фактически – сколько раз встретилась «Москва» в таблице)?

=СУММЕСЛИ(диапазон; условие; [диапазон_суммирования])

  • Диапазон: Город и приход
  • Условие: «Москва» (можно, кстати, было и адрес ячейки написать – A2)
  • Диапазон суммирования: все значения Прихода.

Последний нюанс – зафиксируем диапазон ($A2), чтобы потом просто натянуть форумулу на следующий столбец.

=СУММЕСЛИ($A2:B10; «Москва»; B2:B10)

Я использовал очень простой пример, но функция СУММЕСЛИ гораздо более гибкая – условие ведь может быть любым, даже отдельной функцией. Например, нам нужно суммировать только сегодняшние данные (25 января 2016). Легко:

СУММАЕСЛИ + СЕГОДНЯ()

=СУММЕСЛИ(B2:C10;СЕГОДНЯ();C2:C10)

Количество рейсов.

СЧЕТЕСЛИ

=СЧЁТЕСЛИ(диапазон;критерий)

т.е.:

=СЧЁТЕСЛИ(A2:A10;A2)

Конечно, пара предварительных итераций, и можно было бы обойтись и без СЧЕТЕСЛИ. Мы могли бы добавить столбец Счетчик со значением единица, а потом, составив сводную таблицу, где бы значения счетчика суммировались, увидели количество совпадений. Но, согласитесь, при должном контроле над таблицей, использование этих функций и быстрее и круче.

Share Button

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *