EXCEL: как выбрать несколько наибольших значений из ряда чисел?

Имеется массив данных. Как выбрать из него несколько наибольших значений. Одно самое большое число легко находилось бы функцией МАКС, но что если нужно найти больше 1 числа?

Например, у нас есть несколько этапов спортивных состязаний. Спортсменам, по результатам каждого турнира начисляют зачетные очки. Всего этапов 6, но в финальный зачет идут три лучших результата любого из 6 этапов. Верхняя часть таблицы:

Таблица общего зачета

Нам поможет функция НАИБОЛЬШИЙ(массив;k), где:

  • Массив – диапазон выборки, в нашем случае – строка.
  • K – искомая позиция значения в диапазоне. 1 – ищем самое большое число, 2 – второе по величине, 3 — третье и т.д.

Т.о. нам нужно найти:

=НАИБОЛЬШИЙ($B2:$G2;1)

=НАИБОЛЬШИЙ($B2:$G2;2)

=НАИБОЛЬШИЙ($B2:$G2;3)

Если в таком виде растянуть формулу на все строки, в некоторых ячейках мы получим ошибку #ЧИСЛО! (не число), т.к. спортсмен мог не участвовать в соревновании или не занять место в очковой зоне. Кстати, аналогичную ошибку получим, если k меньше или равно 0 или если k больше количества значений в диапазоне (например, мы попытаемся найти седьмое по величине число из 6)

Делаем дополнительную проверку функцией ЕСЛИОШИБКА, заменяя пустую ячейку на 0:

=ЕСЛИОШИБКА(НАИБОЛЬШИЙ($B2:$G2;1);0)

Итого по 3 Лучшим

Почти все. Теперь просто суммируем три наибольших значения, сортируем таблицу или делаем другие нужные нам действия.

Share Button

One thought on “EXCEL: как выбрать несколько наибольших значений из ряда чисел?”

  1. Формула будет ссылаться на значения, хранящиеся в диапазоне ячеек E1 – G3 на листе «Данные». Альтернатива использованию данной формулы массива с несколькими ячейками – вставить отдельную формулу в каждую ячейку листа «Массивы» указанным ниже образом.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *