Excel: выделяем цветом ячейки по дням недели, будни и выходные

В заголовок я вынес частный случай одного очень удобного способа оформить данные на листе. Предложим, у вас есть колонка дат, и вы бы хотели автоматически выделять разным цветом ячейки рабочих и выходных дней. Или, можно таким же способом выделить своим цветом  каждый день недели. Больше того, этот универсальный способ позволяет строить в excel конструкции вида: ЕСЛИ условия такие-то, ТО цвет ячейки (а также шрифт, границы, формат данных!) такой-то.

Можно решать подобную задачу с помощью макроса, но я хочу показать, как это сделать, используя только меню EXCEL. Поехали.

Имеется столбец А с датами. Если нужно получить из этих данных дни недели, то самый простой способ, это выбрать Формат ячеек – Все форматы и в строке тип написать ДДД или ДДДД. Отобразится полный или сокращенный день недели. На скриншоте у меня приведен сокращенный вариант (ДДД)

Получить исходя из даты числовое значение дня недели можно с помощью формулы:

=ДЕНЬНЕД(A1;2)

Двойка после значения в ячейке это тип отображаемых данных. По умолчанию или тип 1: единица – воскресенье, а семерка – суббота. Нам как-то привычнее считать, что суббота это шестой день недели, а воскресенье – седьмой. Поэтому укажите тип – 2.

Применительно к нашей задаче, если нам важно лишь будний это день или выходной, я воспользовался такой формулой:

=ЕСЛИ(C1<6; «РАБ»; «ВЫХ»)

excel-color-days-0

Все прекрасно, но что насчет цветового форматирования? Становимся на соседнюю ячейку и выбираем в меню Главная – Стили – Условное форматирование – Создать правило

excel-color-days-1

Нам нужен пункт Использовать формулу для определения форматируемых ячеек

excel-color-days-2

В формуле кликаем на ячейку слева, пишем =“РАБ”. Аналогично для выходных дней, =”ВЫХ”. По кнопке «Формат» настраиваем внешний вид ячейки, с нашем случае это только цвет заливки.

excel-color-days-3

Вернуться к редактированию уже существующих правил, удалить или создать новое правило можно через пункт меню Условное форматирование – Управление правилами

excel-color-days-4

Почти получилось. Но при попытке растянуть условия курсором на другие ячейки столбца вы увидите проблему. Дело в том, что по умолчанию в условии проставляются абсолютные ссылки (знак $). Выбираем снова Условное форматирование – Управление правилами – Изменить правило и аккуратно удаляем знаки доллара, в нашем примере должно получиться, для рабочих дней:

=D1= «РАБ»

Для выходных:

=D6= «ВЫХ»

Теперь смело растягиваем ячейки с примерами на весь столбец и получаем итоговый результат:

excel-color-days-5

Естественно, все это можно было делать и в одной и той же ячейке столбца А. Надеюсь, что-то из перечисленного вам поможет и упростит работу с таблицами!

Share Button

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.